WANPIPE Requirements


Requirements

Wanpipe requires a list of packages on your system prior to installed. The Setup script will check for those packages prior to installation.
Confirm that you have all the packages installed:

Wanpipe Driver Minimum Requirements

C developement tools …(gcc)
C++ developement tools
Make utility
Ncurses library
Perl developement tools
AWK
FLEX
Patch
libtermcap-devel
bison
libtools
autoconf
automake

For BRI/SGM

sctp utilities
asterisk source


Note: The following assumes your linux distribution uses “yum” or “apt” package managers, adjust to your distros package manager (for example Suse uses “yast”).

YUM packages – required for wanpipe drivers/modules:

yum -y install make
yum -y install ncurses
yum -y install ncurses-devel
yum -y install gcc*
yum -y install awk*
yum -y install flex
yum -y install patch
yum -y install libtermcap-devel
yum -y install bison
yum -y install libtool
yum -y install autoconf
yum -y install kernel-devel-$(uname -r)
yum -y install automake

APT-GET packages – required for wanpipe drivers/modules

apt-get -y install build-essential
apt-get -y install gcc
apt-get -y install g++

apt-get -y install automake
apt-get -y install autoconf
apt-get -y install libtool
apt-get -y install make
apt-get -y install libncurses5-dev
apt-get -y install flex
apt-get -y install bison
apt-get -y install patch
apt-get -y install libtool
apt-get -y install linux-source-$(uname -r)
apt-get -y install linux-headers-$(uname -r)
apt-get -y install libsctp-dev

Yast Packages – required for wanpipe drivers/modules

yast -i kernel-pae-devel
yast -i libtool
yast -i gcc
yast -i patch
yast -i perl
yast -i bison
yast -i gcc-c++
yast -i ncurses
yast -i ncurses-devel
yast -i flex
yast -i compat-readline4
yast -i termcap
yast -i lksctp-tools-devel 
yast -i autoconf
yast -i automake
yast -i libxml2


SMG required packages – required if you want to install Sangoma Media Gateway:
Note: SMG is required when using BRI (AFT-A500) and Wanpipe SS7.

1. SCTP development tools
use “yum install lksctp-tools-devel” or “apt-get install libsctp-dev”.

Advertisements

One thought on “WANPIPE Requirements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

shisdew

Listens until think alike

moses.spaceku@yahoo.com / voip ipbx

Hosted PBX, IP-PBX SOHO/ CALL CENTER, VOICE GATEWAY, VOICE CARD, COST EFECTIVE SOLUTIONS (LCR), GSM/CDMA GATEWAY

%d bloggers like this: